
SKILLSCOMMONS ACCESSIBILITY 
CHECKPOINTS

METHODS FOR EVALUATING THE ACCESSIBILITY OF 
PDF DOCUMENTS

(NON-ASSISTIVE TECHNOLOGIES)



Methodology
•Designed by

•CUDA and CSU-MERLOT
•In partnership with CAST

•Applied by
•The California State University on the 
California Open Online Library Project 
(www.cool4ed.org)

http://web.csulb.edu/centers/cuda/
https://www.merlot.org/merlot/index.htm
http://www.cast.org/
http://www.cool4ed.org/


Non-Assistive Technologies Evaluation
The “Non-Assistive Technologies (NAT) Evaluations” address readily 
available tools such as the keyboard and navigation typically found on our 
devices and are typically available to the general public



Accessibility Checkpoints
1. Accessibility 

Documentation
2. Text Access
3. Text Adjustment
4. Reading Layout
5. Reading Order
6. Structural 

Markup/Navigation
7. Tables

8. Hyperlinks
9. Color and Contrast
10. Language
11. Images
12. Multimedia
13. Flickering
14. STEM
15. Interactive Elements



Accessing PDF documents

STEPS:
1. Visit SkillsCommons site at www.skillscommons.org
2. Search for and download desired PDF document



Accessing PDF documents

STEPS:
1. Visit SkillsCommons site at www.skillscommons.org



Accessing PDF documents

STEPS:
2. Search for and download desired PDFdocument

Click on PDF document 
to download.



Skills Commons Accessibility Checkpoints

All information obtained from the WORD document evaluation 
will be entered into the SkillsCommons Accessibility Checkpoints 
document:

Enter info 
such as the 
pages you 
evaluated 
here as well.

http://support.skillscommons.org/documentation/SkillsCommons-Accessibility-Checkpoints-Evaluation-Form.pdf


Pass, Fail, or N/A?
• Evaluate material based on the amount of material 

included in the checklist

• Example: Evaluate 10 links for flickering
7 / 10 links - PASS
6/10 links - FAIL

N/A cannot be used here!



• Ratings are on a scale of 1-10

Ratings

1 5 10
Fail Pass

• Failure to meet a checkpoint (Fail) should not be rated 
above a 7

• Meeting a checkpoint (Pass) should not be rated below a 7

7

|



Evaluating Accessibility of 
PDF documents 



PDF Evaluation Requirements

OS 
• Windows OS (XP or above)

Require Downloading
• Adobe Acrobat Pro XI or DC (DC: Download, $449)
• Color Contrast Analyzer- CCA (Download)
** Following screenshots are done with Adobe Acrobat Pro XI

https://acrobat.adobe.com/us/en/pricing/pricing.html?cmpgn=sembrandbuy&sdid=KARFP&skwcid=AL!3085!3!70518882862!e!!g!!adobe%20acrobat%20%2Bpro&ef_id=VRLvXwAABYOznjX8:20150721152628:s
http://www.paciellogroup.com/resources/contrastanalyser/


1. Accessibility Documentation

For the documents’ organizations, find the following:
☑ URL to formal Accessibility Policy
☑ URL to accessibility statements
☑ URL to Accessibility Evaluation Report



2. Text Access

☑ The text of the digital resource is available to assistive 
technology that allows the user to enable text-to-
speech (TTS) functionality 

◉ Amount of Material to Be Evaluated

*** Sample 5 pages ***



STEPS:

1. Open file with Adobe Acrobat XI Pro

2. View > Read Out Loud > Activate
3. Select Read This Page Only when you are on the 

page you would like to evaluate.

2. Text Access

◉ Amount of Material to Be Evaluated
*** Sample 5 pages ***



2. Text Access



3. Text Adjustment (Size)

☑ The text allows the user to adjust the font size



3. Text Adjustment (Size)
STEPS:
1. Open file with Adobe Acrobat XI Pro
2. Edit > Preference >Accessibility
3. Select Always use Zoom Setting > Reflow (drop down)
4. Click OK
5. CLOSE Adobe Acrobat Pro
6. Open the file with Adobe Acrobat Pro again
7. Zoom in and out to see if the text adjust its size to fit the 

screen
8. Remember to deselect Always use Zoom Setting > click ok > 

close and reopen the file (to keep everything in original format for the rest 
of the evaluation)



3. Text Adjustment (Size)

◉ Amount of Material to Be 
Evaluated

*** Sample 5 pages ***



3. Text Adjustment (Color)
☑ The text allows the user to adjust the font/background 

color



STEPS:
1. Open file with Adobe Acrobat XI Pro
2. Edit > Preference >Accessibility
3. Select Replace Document Colors > Green text on Black 

(drop down)
4. Click OK
5. Remember to deselect Replace Document Colors > click 

OK > close and reopen the file (to keep everything in original format for 
the rest of the evaluation)

3. Text Adjustment (Color)



3. Text Adjustment (Color)

◉ Amount of Material to 
Be Evaluated

*** Sample 5 pages***



4. Reading Layout (reflow)
☑ Text of the digital resource is compatible with assistive 

technology that allows the user to reflow the text by 
specifying the margins and line spacing

◉ Amount of Material to Be Evaluated

*** Sample 5 pages ***



4. Reading Layout (reflow)
STEPS:
1. Open file with Adobe Acrobat XI Pro
2. Edit > Preference >Accessibility
3. Select Always use Zoom Setting > Reflow (drop down)
4. Click OK
5. CLOSE Adobe Acrobat Pro
6. Open the file with Adobe Acrobat Pro again
7. Zoom in and out to see if the text reflows
8. Remember to deselect Always use Zoom Setting > click ok > 

close and reopen the file (to keep everything in original format for the rest 
of the evaluation)



◉ Amount of Material to Be 
Evaluated

*** Sample 5 pages ***

4. Reading Layout (reflow)



4. Reading Layout (# of pages)
☑ If the digital resource is an electronic alternative to 

printed materials, the page numbers correspond to the 
printed material 

**Skip this subsection: We don’t have the printed 
version**



5. Reading Order

☑ Reading order for digital resource content logically 
corresponds to the visual layout of the page when 
rendered by assistive technology 

◉ Amount of Material to Be Evaluated

*** Sample 5 pages ***



5. Reading Order

STEPS:
1. Open file with Adobe Acrobat XI Pro
2. Locate 5 pages ( include page # in the reports) that 

contains a more complicated layout
3. Use the Read Out Loud function to check if the reading 

order is logical (please refer to checkpoint #2 for 
instructions on Read Out Loud)
◉ Amount of Material to Be Evaluated

*** Sample 5 pages ***



6. Structural Markup / Navigation

☑ The text of the digital resource includes markup (e.g. 
tags or styles) that allows for navigation by key 
structural elements (chapters, headings, pages) using 
assistive technology 

☑ The text of the digital resource includes markup for 
bullets and numbered lists that is compatible with 
assistive technology



☑ If the text of the digital resource is delivered within an 
ebook reader application, a method is provided that 
allows users to bypass the reader interface and move 
directly to the text content that is compatible with 
assistive technology 

6. Structural Markup / Navigation



6. Structural Markup / Navigation
• Adobe Acrobat Pro: Accessibility Checker

1. Open the file in Adobe Acrobat Pro XI
2. Select Accessibility Tools 



3. Select Full Check.
6. Structural Markup / Navigation



4. Select the Start Checking button to begin the full check.
6. Structural Markup / Navigation



Results: Check for Tagged PDF, Title, Bookmarks, and Headings
6. Structural Markup / Navigation



7. Tables

☑ Data tables include markup (e.g. tags or styles) that 
identifies row and column headers in a manner that is 
compatible with assistive technology 



7. Tables
• Adobe Acrobat Pro: Accessibility Checker

1. Open the file in Adobe Acrobat Pro XI
2. Select Accessibility Tools 



3. Select Full Check.
7. Tables



4. Select the Start Checking button to begin the full check.
7. Tables



Results
7. Tables



7. Tables
• Additional Manual Check
STEPS:
1. Select a table in the text
2. Activate the read-out-loud function (please refer to 

Checkpoint #2)
3. Use the read-out-loud function to read the current page 

(Shift + Ctrl + V)
4. Repeat the steps to check for 5 tables 

*** Sample 5 tables ***



8. Hyperlinks
☑ Functionality: Links (e.g. website or email addresses) within 

the text of the digital resource are rendered as active 
hyperlinks in a manner that allows them to be detected and 
activated with assistive technology 

☑ Descriptive: The link is descriptive enough for the users to 
know where the link will take them. If the link appears as an 
URL = fail this sub category.

☑ Checking for both in-document links and live hyperlinks



8. Hyperlinks (in-document)
• Adobe Acrobat Pro: Accessibility Checker

1. Open the file in Adobe Acrobat Pro XI
2. Select Accessibility Tools 



3. Select Full Check.
8. Hyperlinks (in-document)



4. Select the Start Checking button to begin the full check.
8. Hyperlinks (in-document)



Results
8. Hyperlinks (in-document)



8. Hyperlinks (in-document)

◉ Amount of Material to Be Evaluated
*** Sample 30 in-book links ***
10 from the beginning of the document
10 from the middle of the document
10 from the end of the document

Ex. Links that takes you to a certain chapter

Check for descriptive links when going 
through each link manually. 

1. Check for Navigation links in Results
2. Manual check



8. Hyperlinks (Live)

STEPS:
Use Tab key to navigate through links 
> Press enter when you find a live 
hyperlink (Check for functionality and 
descriptive link at the same time)

◉ Amount of Material to Be Evaluated
*** Sample 20 website hyperlinks ***

Hyperlink that takes you somewhere outside of the 
document
Ex. Links to a live website



9. Color & Contrast (Color Redundancy)
☑ Color redundancy (information is not conveyed by color 

alone) needs to be checked manually 

◉ Amount of Material to Be Evaluated

*** Sample 5% of the pages ***



☑ The visual presentation of text and images of text in the digital 
resource has a contrast ratio of at least 4.5:1 

STEPS:
1. Download Colour Contrast Analyzer Tool 
2. Open the document you want to evaluate
3. Open the application
4. Make sure you are in the Result --Luminosity mode.
5. Click the Foreground eye dropper tool, hover over and click the 

foreground color to select it.
6. Click the Background eye dropper tool, hover over and click the 

background color.
7. Check and compare the ratio to 4:5:1

9. Color & Contrast (Contrast Ratio)

http://www.paciellogroup.com/resources/contrastanalyser


Color & Contrast (Contrast Ratio)
Colour Contrast Analyzer 
(CCA)
1. Download Colour 

Contrast Analyzer 
Tool 

2. Open the document 
you want to evaluate

3. Open the application

http://www.paciellogroup.com/resources/contrastanalyser


Color & Contrast (Contrast Ratio)
4. Make sure you are in 

the Result --
Luminosity mode.

5. Click the Foreground eye 
dropper tool, hover over 
and click the foreground 
color to select it.



Color & Contrast (Contrast Ratio)
6. Click the Background eye 

dropper tool, hover over 
and click the background 
color.

7. Determine if the text is 
greater than 18 points (e.g. 
Header).

Small text: Check under “Text”
Large text (18+): Check under 
“Large text”



Color & Contrast (Contrast Ratio)

◉ Amount of Material to Be Evaluated

Contrast Ratio

*** Sample 5% of the pages ***



10. Language

☑ The text of the digital resource includes markup that 
declares the language of the content in a manner that is 
compatible with assistive technology

☑ If the digital resource includes passages in a foreign 
language, these passages include markup that declares 
the language in a manner that is compatible with 
assistive technology 



• Adobe Acrobat Pro: Accessibility Checker
1. Open the file in Adobe Acrobat Pro XI
2. Select Accessibility Tools 

10. Language



3. Select Full Check.
10. Language



4. Select the Start Checking button to begin the full check.

10. Language



Results
10. Language



11. Images
☑ Non-decorative images have alternative text that is 

compatible with assistive technology (or is rendered by an 
application such as a browser, media player, or reader that 
offers this functionality) 

☑ Decorative images are marked with null alternate text or 
contain markup that allows them to be ignored by assistive 
technology 

☑ Complex images, charts, and graphs have longer text 
descriptions that are compatible with assistive technology 



• Adobe Acrobat Pro: Accessibility Checker
1. Open the file in Adobe Acrobat Pro XI
2. Select Accessibility Tools 

11. Images



3. Select Full Check.
11. Images



4. Select the Start Checking button to begin the full check.

11. Images



Results
11. Images



◉ Check manually: Make sure the descriptions for the images 
are descriptive enough for both non-decorative images and 
complex images.

◉ Amount of Material to Be Evaluated for non-decorative and 
complex images:
*** Sample 10 images each***

◉ Rule of thumb: if the image cannot be described in one 
sentence, it’s complex!

11. Images (Additional Manual Check)



12. Multimedia
☑ A synchronized text track (e.g. open or closed captions) 

is provided with all video content
☑ A transcript is provided with all audio content
☑ Audio/video content is delivered via a media player that 

is compatible with assistive technology



12. Multimedia
1. Check for Tagged Multimedia in Results
2. Manual Check for synchronized text and 

transcript.



12. Multimedia (Synchronized Text)
1. Find multimedia
2. Search for availability of a text track (e.g., CC)



12. Multimedia (Transcript)
1. Find multimedia
2. Search for availability of a transcript



12. Multimedia (Transcript)



12. Multimedia
◉ Amount of Material to Be Evaluated

*** Sample a minimum of three videos, if applicable***



13. Flickering
☑ Resources should not contain 

anything that flashes more than 
three times in any one-second 
period

***Check for Screen Flicker in Results



14. STEM

STEM: Science, Technology, Engineering, and Math

☑ STEM content is marked up in a manner that is 
compatible with assistive technology 



☑ The resource conveys both the notation (presentation) 
and meaning (semantics) of the STEM content

STEPS:
1. Manually check that the following have a description 

that conveys notation and meaning
• Figures
• Graphs
• Equations/Tables

14. STEM



Manually check that all 
figures, graphs, and 
tables have a description 
that conveys notation and 
meaning

14. STEM



Labels, descriptions, or tags should be 
descriptive

14. STEM



For BOTH Markup and Notation:
1. Select a STEM content in the text
2. Activate the read-out-loud function (please refer to Checkpoint #2)
3. Use the read-out-loud function to read the current page (Shift + Ctrl 

+ V)
4. Repeat the steps to check for 10 STEM content in each sub-section 

14. STEM

Did read-out-loud 
read this correctly?



15. Interactive Elements
☑ Keyboard

Interactive elements allow for keyboard-only operation 
WITH and WITHOUT assistive tech

***Mark N/A in the accessibility checkpoint (.xsls) and Skills 
Commons Checkpoint (.docx) if the text contains no 
Interactive Elements for all subcategories under checkpoint 
15***



15. Interactive Elements
STEPS:
• Without assistive technology, use the TAB key to 

navigate the menu
• Items that are selected will have a box around the link 
• Use the ENTER key to select a link or other item



☑ Markup
Each interactive element conveys information to 
assistive technology regarding the element’s
☑name
☑type
☑status

15. Interactive Elements



☑ Text prompts
The following are conveyed with assistive technology:
☑Instructions
☑Prompts
☑Error messages

How to:
Use Tab key to activate the interactive elements and check 
if you receive any text prompts.

15. Interactive Elements



This work is licensed under a Creative Commons Attribution 4.0 International License.
This workforce solution was created through a cooperative agreement between the U.S. Department of 
Labor's Employment and Training Administration and the California State University-Multimedia 
Educational Resource for Learning and Online Teaching (MERLOT).

Creative Commons Attribution License
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